Some Plugins Left Behind as WordPress Moves Forward
By admin On 15 Aug, 2011 At 03:32 PM | Categorized As Our Latest Posts, Wordpress | With 0 Comments

There is always a price for progress and in the case of WordPress that price is that some plugins get left behind.

For years developers have been actively creating exciting plugins that have really pushed the boundaries of what it is possible to do with the platform. Some of the things that they’ve done have even been so popular that versions of them have been incorporated into WordPress itself.

But as WordPress releases newer updates, some plugins ‘break’ due to changes within the code itself. Some developers keep their plugins up to date, but many don’t. Today, if you were to browse through the plugin repository you’ll notice quite a few plugins that haven’t been updated for years on end!

Simple Statistics

Going over the plugin repository can be tedious – but here are some statistics that should raise your eyebrows (to say the least):

• About two-thirds of the plugins available on the repository haven’t been updated in 2011 (this year).
• About half of the plugins available are compatible with WordPress versions about 3.0 (i.e. WordPress 3.0, WordPress 3.1, and WordPress 3.2).
• Only 15% of the plugins run with zero problems or errors on WordPress 3.2

It is obvious from the statistics that a lot of the plugins out there aren’t really fully working on the latest version of WordPress – and that is a big deal, believe it or not.

Why is this a Problem?

Okay so facts are facts and you should accept by this stage that there are quite a lot of plugins that have been left behind and are gathering dust in the WordPress plugin repository – but so what?

Does anyone really care if some obscure plugin hasn’t been updated? Does it really matter?

To the vast majority of users it doesn’t. Most WordPress users would only install the latest and most up-to-date plugins that are popularly used. But from time to time you may be looking for something specific and come across a certain plugin that ‘appears’ to do exactly what you’re looking for.

But it might not be updated.

Some people would still attempt to install these plugins – and that’s where the problems begin. Old plugins can often cause certain vulnerabilities, crashes, and even destabilize WordPress. If they simply don’t install, that’s not a huge deal – but what happens when they do install and then create a security issue that you don’t know about?

The easiest way around this is to make sure that you only install plugins that are at least WordPress 3.0 compatible and upwards. Old plugins aren’t worthless, but they are getting there as the risks involved in using them (as you now know) are high.

Leave a comment

XHTML: You can use these tags: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>